Beta 2 client V0.7.1 not supported

TreizeTreize philippines-chessapeake
I downloaded the new client just now but when I tried launching and connecting to the CB2 shard, Im getting a message this version is no longer supported. Is the new client up already?

Comments

  • MarklesMarkles United States
    Same problem, I'm assuming the new client version will be automatically installed when the server maintenance has settled.
  • Probably not your issue, but just encase, did you make sure that the launch icon you might be clicking is not pointing to an old install?
  • same here
  • TarosTaros Suhh
    I'm having the same issue, damn
  • I am able to login with no issue, for this version
Sign In or Register to comment.